Maven依赖冲突

依赖的原则主要是为了解决模块之间jar包冲突问题。
我们分两种情况说明一下:

路径最短者优先

例如:当我们工程Animal依赖Cat,Cat又依赖Action,每个单独工程中Action依赖log4j-1.2.17,Cat依赖log4j-1.2.14,那我们的Animal工程要依赖于哪个版本呢?其实Maven为我们提供了内置的原则,就是路径最短者优先,我们的Animal工程最终依赖的是log4j-1.2.14

路径最短者优先

路径相同先声明优先

例如:当我们工程Animal同时依赖Cat,又依赖Action,每个单独工程中Action依赖log4j-1.2.17,Cat依赖log4j-1.2.14,这时候依赖的路径是相同的,那我们的Animal工程最终依赖的是哪个版本呢?

路径相同先声明优先

这个时候我们要看这两个jar文件在pom文件声明的先后顺序,优先声明者先依赖。

统一管理依赖的版本

<properties>
	<!-- 在properties里面统一管理依赖的版本 -->  
	<spring-boot.version>2.1.3.RELEASE</spring-boot.version>
	<spring-cloud-starter-alibaba.version>0.9.0.RELEASE</spring-cloud-starter-alibaba.version>

	<maven.compiler.source>1.8</maven.compiler.source>
	<maven.compiler.target>1.8</maven.compiler.target>
</properties>

<dependencies>
	<dependency>
		<groupId>org.springframework.boot</groupId>
		<artifactId>spring-boot-starter-web</artifactId>
		<version>${spring-boot.version}</version>
	</dependency>
	<dependency>
		<groupId>org.springframework.cloud</groupId>
		<artifactId>spring-cloud-starter-alibaba-nacos-discovery</artifactId>
		<version>${spring-cloud-starter-alibaba.version}</version>
	</dependency>
	<dependency>
		<groupId>org.springframework.boot</groupId>
		<artifactId>spring-boot-starter-actuator</artifactId>
		<version>${spring-boot.version}</version>
	</dependency>
</dependencies>

为了统一管理版本号,可以使用properties标签,里面可以自定义版本的标签名。在使用的地方使用${自定义标签名}

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页